fCraft Forums
http://forum.fcraft.net/

Log-in Issues? - LauncherX, Charged Miners, WoM
http://forum.fcraft.net/viewtopic.php?f=14&t=2893
Page 1 of 2

Author:  LiamRayStanley [ March 10th, 2012, 10:33 pm ]
Post subject:  Log-in Issues? - LauncherX, Charged Miners, WoM

There is no built-in /fly command in fCraft. Instead, you should use a Minecraft client capable of flight! You have several options:

Option 1: ClassiCube client (recommended)
Show

Option 2: World of Minecraft (WoM) client
Show

Option 3: LauncherX (WoM fix) (Requires WoM)
Show

Option 4: Charged Miners (currently broken)
Show

Option 5: XWoM (WoM Enhancement) (Requires WoM)
Show

Author:  LiamRayStanley [ March 11th, 2012, 6:25 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Posted a video tutorial

Author:  tomsplz3 [ March 12th, 2012, 11:28 am ]
Post subject:  Re: For WoM Users. Error Logging in

reccomending a sticky thing on this since it does infact work

Author:  Aleries [ March 12th, 2012, 10:27 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Changed to a Global announcement so now there is no reason for not seeing it. Will hopefully eliminate anymore "WhY meh Wom no w0rkz?? D: " threads.

Author:  Smokeybacon [ March 12th, 2012, 11:03 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Windows users can do the same fix in the registry entry of wom: HKEY_CURRENT_USER/Software/JavaSoft/Prefs/minecraft.

The string titles are self explanatory. Just don't touch anything outside the aforementioned folder.

Author:  LiamRayStanley [ March 12th, 2012, 11:54 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Smokeybacon wrote:
Windows users can do the same fix in the registry entry of wom: HKEY_CURRENT_USER/Software/JavaSoft/Prefs/minecraft.

The string titles are self explanatory. Just don't touch anything outside the aforementioned folder.


As this is possible, i dont see how this is helpful. your pretty much doing the same thing, but making it harder lol can you please explain the use of this? im not peskie, just wondering. ill add this to the top post

Author:  PyroPyro [ March 13th, 2012, 1:26 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Note to all: Do NOT share your Direct Connect HASH with others.
People can connect as you on the server.

Author:  LiamRayStanley [ March 13th, 2012, 7:23 pm ]
Post subject:  Re: For WoM Users. Error Logging in

PyroPyro wrote:
Note to all: Do NOT share your Direct Connect HASH with others.
People can connect as you on the server.


yeah i didn't feel like giving everyone my hash lol so im doing a new video a new way. (using .reg files and maybe cmd idk) ill see if i can do something cool :P

Author:  hung_dong [ July 8th, 2012, 11:09 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Thanks for the walk through :) My WOM is up and running again.

Just FYI, you don't need the ")" after your name and before the mppass.

Author:  Hellenion [ July 13th, 2012, 8:07 pm ]
Post subject:  Re: For WoM Users. Error Logging in

It also seems like you now need your e-mail address instead of minecraft username to log in to WoM, I missed that announcement.

However, when selecting from the list, you need to edit the mc:// link to not use your email-address but minecraft username.

ugh.

Author:  BobKare [ July 22nd, 2012, 3:41 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Some guy over at our server replied this to a thread about the same. Note that I have not tested if this works.
Quote:
Looks nice, but I'll just issue a warning here, for the sake of all Windows users:

Always back up your registry before doing changes!

If something goes wrong, your computer might crash!

Know what you are doing, using the registry is like being a surgeon for Windows.

Also, I made this script for all platforms. Create a new bookmark, with the title "Get WoM URL" and the address being the code below:

 
Code:
javascript:prompt("Here's your WoM Code:",'mc:\/\/' + document.getElementsByName("server")[0].value + '\/' + document.getElementsByName("username")[0].value + '\/' + document.getElementsByName("mppass")[0].value);


When you go to the Minecraft.net classic multiplayer site as Paintboy described above here, instead of checking the page's source, open your bookmark!

Notice: For some weird reason, in Google Chrome: If you press OK in the dialog, you will be redirected to a page showing the URL, and the Minecraft site will be closed. If you press Cancel, you'll stay on the same site. No idea why this happens!

I hope it works, just trying to help making it as easy as possible to do this

Author:  RSW0103 [ August 2nd, 2012, 10:22 pm ]
Post subject:  Re: For WoM Users. Error Logging in

Mine says End of Stream.Can anyone tell me how to fix it please?

Author:  Pothus [ August 5th, 2012, 1:24 am ]
Post subject:  Re: For WoM Users. Error Logging in

RSW0103 wrote:
Mine says End of Stream.Can anyone tell me how to fix it please?
Image

If you see an 'End of stream' error whilst playing Minecraft you're playing on the fCraft SMP (Survival Multiplayer) server.

Usually when you get the 'End of stream' notice on Minecraft, it means the server shut itself off and is resetting. The only thing you need to do is wait a few minutes and then turn on the game again maybe close your client and re-open it.

Author:  LiamRayStanley [ August 5th, 2012, 3:12 am ]
Post subject:  Re: For WoM Users. Error Logging in

RSW0103 wrote:
Mine says End of Stream.Can anyone tell me how to fix it please?


If you are attempting to connect to SMP and you get the end of stream it mostlikely means you updated your minecraft to 1.3 which will throw this error i believe. Or your tryign to connect when we have VPN issues on all our server.

If you attempting to connect using WoM (World Of Minecraft) to classic, and you get this error (i just had the same issue which was throwing all kinds of errors, fixed due to the link below), You might have to try to re-sign in and find the fCraft classis in the WoM list. if this error still persists....

You may have migrated your account to a Mojang account, and when you log in you have to use your email. If not ignore this. Otherwise refer to this thread: viewtopic.php?f=2&t=3563

Other players End of stream error for SMP: viewtopic.php?f=28&t=3733

Info for when our SMP upgrades to 1.3: viewtopic.php?f=28&t=3711

Other players Mojang migration issues: viewtopic.php?f=5&t=3596

If this still doesnt help, let me know.

Author:  LiamRayStanley [ August 5th, 2012, 3:42 am ]
Post subject:  Re: For WoM Users. Error Logging in

Smokeybacon wrote:
Windows users can do the same fix in the registry entry of wom: HKEY_CURRENT_USER/Software/JavaSoft/Prefs/minecraft.

The string titles are self explanatory. Just don't touch anything outside the aforementioned folder.


Also for those who have dynamic IP's or cant connect via WoM to fCraft Classic and get the invalid name or whatever and have to re-find the name in the WoM server list, i recommend:

Making a .reg file from a exported registry of the mppass, set to "" or null so to speak. This should make WoM re-fetch the mppass on load. I can make an executable that you place in the same directory of your WoM program, and run the exe instead - Which will wipe the mppass on every load. It doesnt take very long to load the mppass (not even with my slow interent) and is MUCH faster then loading the WoM server list, as i know people with slow internet connections take very long to run a search query (and load the list itself).

Also I'd recommend combining the above with the Minecraft jsp urls that can be used in your bookmarks list.

http://www.minecraft.net/play.jsp?server=<IP>&port=<port>

replace <IP> and <port> with the corresponding server IP and port that the server is located on.

You can find the IP and PORT via the method of viewing the source from teh very top post, or the post that Bobkare made that has the javascript bookmark idea.
Code:
prompt("Current server IP and PORT:",'mc:\/\/' + document.getElementsByName("server")[0].value + '\/' + document.getElementsByName("port")[0].value);

EDIT (More cleaned up):
prompt("Current server IP and PORT:", document.getElementsByName("server")[0].value + ' ' + document.getElementsByName("port")[0].value);


In this case, fCraft Classic IP and PORT are:
Code:
                <param name="server" value="46.163.67.40">
                        <param name="port" value="33600">

So the jsp url would be: http://www.minecraft.net/play.jsp?serve ... port=33600

Of course this is nicer for the static IP servers, but if you have a server that is located on a ISP with dynamic IP then this would be useless. Unless of course they have the server stick to one port like the fCraft classic software does. If you run a server that doesnt have that feature, then id recommend using a program called no-ip (http://www.no-ip.com/) to automatically set your IP to the hostname, which instead of the <param name="server" value="46.163.67.40"> it wouldnt be a IP but a hostname/url type style IP like "classicserver.no-ip.org".

most of this stuff might be useless to others but i hope i can help. Also the jsp URL doesnt work unless you dont ever have to reload your servers in WoM using the server list.

Author:  RSW0103 [ August 13th, 2012, 4:02 am ]
Post subject:  Re: For WoM Users. Error Logging in

yea I was updated.Prest told me about downgrading which i did so i can get back on again.thanx though :)

Author:  MrCupcake [ August 22nd, 2012, 12:16 pm ]
Post subject:  Re: For WoM Users. Error Logging in

You could also get the server link (classic/play/) fro console and paste it on the WoM server list at the URL. it will take you directly to your server with WoM.

Author:  Jonty800 [ October 1st, 2012, 11:46 am ]
Post subject:  Re: For WoM Users. Error Logging in

Hey guys, check out this topic: viewtopic.php?f=6&t=3923

It should be a stress free alternative to doing this.

Offtopic: Omg - do you have any idea how long it took to find out where WoM's registry is located?! And here it is when its too late :P

Author:  Goldenhart88 [ October 21st, 2012, 9:15 am ]
Post subject:  Re: For WoM Users. Error Logging in

hey, goldenhart88 here,
i cant find the mppass anywhere.

Author:  LiamRayStanley [ October 21st, 2012, 7:45 pm ]
Post subject:  Re: Logging in Issues? - LauncherX, Charged Miners, WoM

New methods have been posted for simplicity on the top most thread.

Author:  foot2theballs [ October 30th, 2012, 2:07 am ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

I'm using LauncherX, and I can log in and see the server list just fine. It's when I try to connect to a server-any server-that it will give me a loading bar and then generate a random single player level. Am I doing something wrong or what?

Author:  LiamRayStanley [ October 30th, 2012, 2:44 am ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

Added a temporary fix till LauncherX is fixed. Its under the LauncherX section at the top

Author:  foot2theballs [ October 31st, 2012, 12:50 am ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

Liam, you are a gentleman and a scholar! That registry edit worked for me

Author:  LiamRayStanley [ October 31st, 2012, 1:01 am ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

Glad it worked for you.

Author:  ZeroSpectrum [ November 25th, 2012, 2:38 am ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

Also, for method 4 your direct connect hash can be found on/around line 100 of the source code, just thought I would put that out there.

Author:  Fricksionite [ April 7th, 2013, 12:45 pm ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

This may be somewhat off-course, and probably breaks some talks made in this thread earlier, etc.

I'm just posting this as is. I have only seen the title and the first page of the forums, and I am sharing my L-I Issues.

I am having a very hard time to connect to the server, and actually, a lot of different servers with large world spawns. I am pretty sure that this is the problem I am experiencing. The world chunks would take a lot to load, thus making the connecting hard.

Just sharing my issue.


Ohh yes, if this thread is supposed to be dead and forgotten, forgive me for having posted here.

I am using CM, by the way. I just don't know if it's a CM only problem about the loading.

Author:  LiamRayStanley [ April 7th, 2013, 7:03 pm ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

Fricksionite wrote:
This may be somewhat off-course, and probably breaks some talks made in this thread earlier, etc.

I'm just posting this as is. I have only seen the title and the first page of the forums, and I am sharing my L-I Issues.

I am having a very hard time to connect to the server, and actually, a lot of different servers with large world spawns. I am pretty sure that this is the problem I am experiencing. The world chunks would take a lot to load, thus making the connecting hard.

Just sharing my issue.


Ohh yes, if this thread is supposed to be dead and forgotten, forgive me for having posted here.

I am using CM, by the way. I just don't know if it's a CM only problem about the loading.


Chances are, it is either bad hardware on your end, being a cheap GPU, or you need to update your GPU drivers, for better performance. Often times either the world loads too fast, too slow, or is just too large to be handled by your GPU.

This can be backed up, by people with nice GPU's can join that DontJoin world, that is very large and supposedly detailed. (i've never seen it :P)

Author:  yeetrium [ April 14th, 2013, 10:41 am ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

Hi, I'm new to this forum,
I was using xWOM just fine for months and suddenly when I decided to change the WOM environment settings on my server I tried joining the map that had the new settings and it threw that ambiguous error of "The game broke!" followed by "[java.lang.NullPointerException]"

I then tried to join my server and join the map again, and I was able to join the map. I then wanted to test why this happened, so I then changed the WOM environment settings on my main map to normal and when I joined the client crashed again. Now this time I tried rejoining my server to the main map and the client just froze up on a black screen without even registering a player on the server. I then tried to join other servers with the xWOM patch and the same thing happened, so as of now, I can't use xWOM because it freezes on a black screen before loading a map. I also tried deleting everything in the 'skins' folder and tried joining a server and still the same thing happened.

After all this I tried reinstalling WOM and the xWOM patch in a new folder with a different name and the client worked on other servers! But then when I joined my server the client registered my username on the server but then disconnected with the same error message. I then reconnected and the client just froze up on a black screen before loading a map. Tried joining other servers and the client no longer worked.
I think the client may be throwing a nullPointer exception because it can't find a previous WOM cfg environment file in the 'skins' folder, not sure, but what else could it be? In what directory is all the hidden stuff of WOM placed anyway? For example, when the client would prompt the user if they want to use Hardware or Software acceleration for graphics, where does that option get saved to? Please help find a fix for this because WorldOfMinecraft support for the WOM client is redundant.

I am using Charged Miners for the time being, but I would like to have the MOTD tags of WOM where +hax and +ophax work. And I find the text to be very small on the CM client, a font adjustment option would be nice :)

Wow this came out to be a lot of writing for my first post, but I'm making it as descriptive as possible, thanks in advanced.

Author:  Hellenion [ April 15th, 2013, 2:17 pm ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

I don't use xWOM or WOM myself, but I heard about similar errors, if I recall that correctly it's a bug between minecraft and java7 or something.

You normally spawn high up in the sky but java7 doesn't like that on all maps, could you try moving the spawn location to somewhere on the ground.

Again: I don't use xWOM myself so I wouldn't know what's wrong or why, sorry, I hope someone else around here knows more!

Author:  yeetrium [ April 16th, 2013, 1:31 am ]
Post subject:  Re: Log-in Issues? - LauncherX, Charged Miners, WoM

Hi Hellenion, thanks for the reply.

I have heard of those errors but that is not the case for my computer, because I am running Java 6 Update 43, the latest one for now.

I have heard of that issue of spawning above ground as well, and I've heard high end computers have no problem with that. And I have kept all spawn points touching the ground in order to prevent that from other users trying to join. That shouldn't be an issue.

If you don't use xWOM, what do you use to connect to servers? Charged Miners lately has also crashed while loading the server list, not sure why this is happening either?

And also, anyone have any idea where the user settings for WOM are saved to? I know where the WOM cache is saved to, but I want to know where the settings for using hardware or software acceleration are being saved to.

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/